Non sei ancora registrato? Inizia ora
Registrati  

Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
[RISOLTO][BUG] Comando Guarda lanciato in visuale a 1 colonna

#1
Se si è in visuale in una colonna MA si ha il WIDGET STANZA attivo, ogni volta che cambia qualcosa nella stanza il PG lancia automaticamente un guarda.
Questo potrebbe creare non pochi problemi in caso di MOLTI cambiamenti di stanza in situazioni affollate.
Questa cosa, unita all'altro bug del POPUP inventario ed equip bloccato che ho segnalato nell'altro topic, mi fa pensare che in visuale a 1 colonna sia meglio disattivare automaticamente i suddetti widget
Pensi 'Oh ma perché mi trovo in mezzo a metà dei guai di Landmar?'
Una voce risuona nella tua testa: 'perchè porti sfiga'
Cita messaggio

#2
Eh?
Il problema dell'equip e inventario dovrebbe essere stato già risolto da tempo.
L'autoupdate (o quello che tu chiami Guarda) sul cambio stanza, è voluto. Serve per vedere in tempo reale se qualcuno entra o esce dalla stanza.
Aggiungiamo che tecnicamente è anche un errore perché poi si scaturirebbero problemi nel cliccare un oggetto o un mob che magari è sparito 10 minuti prima (il serve rrisponde "non è qui").
A parte che in questo caso mi sembra molto piu' confusionario così.

Comunque non è un bug, a breve se non ci sono cose aggiuntive chiudo il topic.
Cita messaggio

#3
Eh?
A parte che la visuale a "due colonne non esiste piu'", ma esiste l'attivazione o meno degli widget che sì, apparentemente fanno pensare a 2 colonne o meno.
Ma a parte questo:

Il problema dell'equip e inventario dovrebbe essere stato già risolto da tempo, dove lo avreste riscontrato?
Passaggi per riprodurre il problema? O stiamo parlando di cose vecchie?

L'autoupdate (o quello che tu chiami Guarda) sul cambio stanza, è voluto. Serve per accorgersi in tempo reale se qualcuno entra o esce dalla stanza.
Aggiungiamo che tecnicamente non averlo sarebbe davvero un errore perché poi si scaturirebbero casini casomai provaste a cliccare un oggetto o un mob che magari è sparito 10 minuti prima (il serve rrisponde "non è qui").

Comunque non è un bug almeno non abbia capito male io :? , a breve se non ci sono cose aggiuntive chiudo il topic.
Cita messaggio

#4
Appena riesco a riaccedere tramite webclient provo a rifare tutti i passaggi e a spiegarmi meglio.
Intanto non so perché se provo a connettermi al servizio mi restituisce Error 500
Pensi 'Oh ma perché mi trovo in mezzo a metà dei guai di Landmar?'
Una voce risuona nella tua testa: 'perchè porti sfiga'
Cita messaggio

#5
Allora, premetto che sto usando il webclient in modalità "metà schermo", quindi con la colonna widget nascosta, ho riscontrato i seguenti comportamenti "strani".

WIDGET EQUIPAGGIAMENTO
Quando è attivo, se scrivo i comandi "equip" o "inventario" il popup della schermata corrispondente non compare.
Ipotizzo che sia perché il widget equipaggiamento è attivo, anche se nascosto, e quindi dando il comando il webclient aggiorni quello. Il problema è che, pure se aggiornato, resta nascosto e quindi non consultabile.
Disasttivando il widget e dando il comando il popup equip e inventario salta di nuovo fuori.

Per testare la cosa metti il webclient a metà schermo col widget EQUIPAGGIAMENTO attivo finché la colonna dei widget non scompare, e poi prova a dare il comando INVENTARIO e EQUIPAGGIAMENTO

WIDGET DETTAGLI STANZA
Su questa roba credo di essermi spiegato malissimo. Provo a spiegare meglio il comportamento anomalo che ho riscontrato.
Sempre usando il webclient in modalità a metà schermo, avendo il widget STANZA attivo succedeva che, ogni volta che veniva poggiato un oggetto a terra, veniva preso un oggetto da terra, un mob o un pg entravano in casella, un mob lasciava la casella, etc etc, era come se il PG lanciasse il comando GUARDA che mostrava il nuovo stato di stanza (con la lista pg/oggetti aggiornata a seguito dei comandi di cui sopra).
Questo comportava, in caso di variazioni di oggetti/mob/pg presenti in stanza multipli, una sfilza di GUARDA in rapida successione.
Ora, comunque, provando a replicare questo comportamento mi sembra che la cosa non accada più.
Pensi 'Oh ma perché mi trovo in mezzo a metà dei guai di Landmar?'
Una voce risuona nella tua testa: 'perchè porti sfiga'
Cita messaggio

#6
Ok ora mi torna.
E' un bug sulla mancanza di controlli quando si è a basse risoluzioni e spariscono le colonne per adattarle allo schermo.
Fixo
Cita messaggio



Vai al forum:


Utenti che stanno guardando questa discussione:
1 Ospite(i)