Non sei ancora registrato? Inizia ora
Registrati  

Valutazione discussione:
  • 0 voto(i) - 0 media
  • 1
  • 2
  • 3
  • 4
  • 5
Mac OS Big Sur e client Avenger

#1
Di recente ho effettuato l'aggiornamento al sistema operativo Big Sur e anche dopo aver installato java non mi apre più il vecchio client Avenger. 
Per caso qualcuno ha avuto lo stesso problema ed è riuscito a risolvere?
Cita messaggio

#2
Io riesco ad avviarlo senza problemi da diversi OS.
Purtroppo ci son sempre alcuni glitch grafici che con un po' di ricerca qualcuno mi sembrava fosse riuscito a risolvere.

Non vi nascondo che mi son personalmente messo in comunicazione nei mesi passati con Avenger al fine di poter avere il sorgente originale del client, quantomeno per renderlo utilizzabile ad alter risoluzioni e sistemi moderni per tutti gli affezionati al "vecchio client"

Purtroppo Avenger stesso non e' in possesso del sorgente originale e, per via della struttura con cui gli aggiornamenti venivano gestiti risulta a dir poco controproducente pensare ad aggiornamenti decompilando l'attuale.

Lascio il thread aperto ovviamente, trattandosi di qualcosa completamente diverso.


Ps: penso potrebbe servire far sapere che versione di Java hai installato e come cerchi di avviare il client (e quale versione dello stesso).
Cita messaggio

#3
Ciao,

Prova a mettere la JDK 1.7 (ti conviene switchare tra quella vecchia e nuova perché altrimenti altri software potrebbero non andare).

https://medium.com/@devkosal/switching-j...bc868e686a
Cita messaggio

#4
(11-10-2021, 07:19 PM)Sevaleth - Michele Ha scritto: Ciao,

Prova a mettere la JDK 1.7 (ti conviene switchare tra quella vecchia e nuova perché altrimenti altri software potrebbero non andare).

https://medium.com/@devkosal/switching-j...bc868e686a

Grazie a tutti per le risposte, sono riuscito a risolvere grazie all'aiuto di Ivan/Drazius.

Solitamente aprivo semplicemente avenger.jar col doppio click ma dopo l'aggiornamento a Big Sur java si avviava e chiudeva immediatamente senza restituire alcun messaggio di errore.

Nel mio caso ho in parte risolto così:

brew install telnet

java -jar avenger.jar


Praticamente lancio il client da terminale e funziona esattamente come prima.
Col doppio click sull'avenger continua a darmi lo stesso problema (non si apre) ma giocare con la finestra del terminale aperta non è un problema.

La versione del client che uso: Versione TG++ (DBG) Dec 21 2020 16:04:54
Versione di Java installata: Versione 8 Aggiornamento 301 (build 1,8,0_301-b09
Cita messaggio

#5
Gia', immaginavo fosse questo ed era il motivo per cui facevo presente sarebbe stato utile sapere "come lo avviavi" Smile

Ottimo.
Cita messaggio



Vai al forum:


Utenti che stanno guardando questa discussione:
1 Ospite(i)